이 포스팅은 Gradle 프로젝트에서 라이브러리 버전을 관리하는 방법을 공유합니다.

Lint의 최신 라이브러리 검사 비활성화

Lint의 이슈중 NewerVersionAvailable 이라는 것을 활성화 하면, 원격 리파지토리에 접속하여 특정 라이브러리의 버전을 매번 검사하게 되므로 유용할 수 있지만 안드로이드 스튜디오가 느려질 수 있다. 그래서 난 보통 이 옵션은 비활성화 한다.

최신 라이브러리 검사 하기

NewerVersionAvailable 이슈를 비활성화 하더라도 Gradle sync시마다 해당 리파지토리에서 최신 버전 정보를 내려 받으므로, Lint 검사가 완전히 비활성화 되지는 않는 듯 하다.

그러므로 1.6.0을 참조할 때 다음 이미지와 같이 새로운 버전(1.7.0)을 사용할 수 있다는 안내를 해준다.

의존성 노테이션 위에 커서를 갖다 대고 option + enter를 입력하면 다음과 같이 팝업이 뜨고, “Change to X.Y.Z“을 선택하면 해당 버전으로 변경할 수 있다. 다음의 이미지를 확인하자.

하지만 실무에서는 KTS(코틀린 스크립트)를 사용하면서 다음과 같이 버전관리를 하다보니, 새로운 라이브러리에 대한 Lint 검사가 제외되고 Project Structure에도 의존성이 나타나지 않는 단점이 있다. KTS에 대한 내용은 이전 포스팅을 참고하자.

의존성을 Dependencies 오브젝트(클래스)로 관리
build.gradle.kts의 dependencies 항목

Gradle 플러그인을 통한 최신 라이브러리 확인 (Gradle Dependency Updates)

위에서 언급한 단점을 해결하기 위해 추가적으로 플러그인을 설치할 수 있다.

Gradle Dependency Updates 는 아주 유용한 플러그인이며, 평점 4.7로 좋은 평가를 받고 있다. 만든이의 github 에서 소스코드도 확인할 수 있다. (AGP 업데이트로 오류가 발생했는데 만든이가 대응 안해주면, 직접 플러그인을 수정하도록 하자. 응?)

이 플러그인을 이용하면 기본적으로 우측의 Dependency updates 을 통해 최신 버전의 라이브러리를 가시적으로 확인할 수 있다.

이 라이브러리의 장점은 탭이 펼쳐졌을 때 원격 리파지토리에서 해당 의존성의 최신 버전을 탐색한다는 점이다. 또한 Android Studio에서 androidx.core:core-ktx가 1.7.0이 새로운 버전이라고 나타내는 것과 달리 리파지토리에는 최신버전인 1.8.0이 존재함을 알 수 있다.

만약 private 리파지토리를 관리한다면 임의로 추가 가능하며, unstable 버전을 참고 하는 것도 가능하다. 다음의 이미지를 확인하자.


후원하기

카테고리: Tutorial

4개의 댓글

최우성 · 2022년 6월 2일 1:39 오후

잘보고있습니다.

다른라이브러리를 쓰고있었는데 해당플러그인을사용하니 편해진것같아요

    Charlezz · 2022년 6월 17일 2:52 오후

    감사합니다ㅎㅎ

성빈 · 2022년 6월 16일 12:04 오전

좋은 정보 감사합니다!

    Charlezz · 2022년 6월 17일 2:51 오후

    감사합니다!

최우성 에 답글 남기기 응답 취소

Avatar placeholder

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다.