회사에서 쓰는 아이맥 Android Studio에서 gradlew 커맨드를 쓰려고 하니, java 9.0.x에서는 알아들을수 없는 커맨드라고 나온다…
난 자바를 업데이트한적이 없는데…
 
왜 인지 모르겠지만 다운그레이드 하기로 맘먹고 자바8을 설치했지만 여전히 9.0.x버전이 건재하다.
 
그래서 다음 순서대로 셋팅했다.
 
Step 1: Install Java 8
다운로드: http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
Step 2: 자바8을 설치한뒤, 모든 설치된 자바 버전을 확인한다.

/usr/libexec/java_home -V

Step 3: .bash_profile을 수정하자

sudo nano ~/.bash_profile

Step 4: 아래의 라인을 bash_profiled에 추가해서 1.8 버전을 기본값으로 셋팅한다.

export JAVA_HOME=$(/usr/libexec/java_home -v 1.8)

CTRL+X나 Y 를 눌러 저장, 종료 하자
Step 5: bash_profile을 다시 로드 하자

source ~/.bash_profile

Step 6: 현재의 자바버전을 확인하자

java -version

 
참고: https://stackoverflow.com/questions/46513639/how-to-downgrade-java-from-9-to-8-on-a-macos-eclipse-is-not-running-with-java-9

Buy me a coffeeBuy me a coffee
카테고리: Androidetc

0개의 댓글

답글 남기기

이메일은 공개되지 않습니다.